FIX PROBLEM: Your server is running PHP version but WordPress 5.1.6 3.2.1 5.2.4 Requires at Least.

Notice for all is not well known that to install or do upgradeCPC to a newer version of 3.2It is necessary that be installed a newer version of 5.2.4.

If the server is install a version of PHP older than 5.2.4 to install version WordPress 3.2.1, will appear error / Message "Your server is running PHP version 5.1.6 Requires WordPress 3.2.1 But at Least 5.2.4".
The problem can be solved very simply by upgrading PHP, but before doing so a few things should be considered. First, upgrade PHP hosting is excluded from a share. So you can do the upgrade must have administrator access to the server (dedicated server or VPS). In the second, before the upgrade must be careful to document and that new version of PHP not to give Errors other sites hosted on that server.

because OS is the most widely used web servers (Agreart and / WHM) Will show you how to do upgrade to PHP on CentOS 5.2.10.x 5 32-bit.

Upgrade to PHP 5.1.x 5.2.x on 5-bit CentOS 32.x

1. Check which packages / modules are installed PHP (ex. Php-mcrypt) in addition to standard packet. If any, they will be deleted or actuzlizate.

Check the installed packages:

rpm-qa | grep php

old_php_version

2. Add new archives required upgradePHP version acquis.

nano / etc / yum.repos.d / CentOS-Testing.repo

In the newly created file (CentOS-Testing.repo) Will add the lines below (copy / paste):

[C5-testing]
name = 5 CentOS-Testing
baseurl = http: //dev.centos.org/centos/$releasever/testing/$basearch/
enabled = 1
gpgcheck = 1
gpgkey = http: //dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X to save file CentOS-Testing.repo.

3. PHP update via yum:

yum update

4. Restart / httpd :

service httpd restart

After the restart httpd version and check the installed packages:

new_php_version

Check for errors modules / packages:

php-v

Upgrade PHP / 32-bit CentOS (i386).

FIX PROBLEM: Your server is running PHP version but WordPress 5.1.6 3.2.1 5.2.4 Requires at Least.

About the author

Stealth LP

Founder and editor Stealth SettingsIn 2006 date.
Experience on Linux operating systems (especially CentOS), Mac OS X, Windows XP> Windows 10 and WordPress (CMS).

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment is processed.